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ACRONYMS 
AOI – area of interest 

ASL – above sea level 

CCI25 – IMAP EO8 Candidate Common Indicator 25 “Land cover change” 

CGLS-LC100 – Copernicus Global Land Services: Land Cover 100 m 

CRS – coordinate reference system 

DEM – digital elevation model 

EO8 – IMAP Ecological Objective 8 “Coastal ecosystems and landscapes” 

EPSG – European Petroleum Survey Group 

ETRS89/LAEA – European Terrestrial Reference System 1989 / Lambert Azimuthal Equal Area 

EU – European Union 

FABDEM – Forest and Buildings removed Copernicus DEM 

FOSS – free and open source 

GDAL – Geospatial Data Abstraction Library 

GeoJSON – geospatial data interchange format based on JavaScript Object Notation (JSON) 

GeoTIFF – Geographic Tagged Image File Format 

GIS – geographic information system 

GPKG – GeoPackage 

IBAT – Integrated Biodiversity Assessment Tool 

IMAP – Integrated Monitoring and Assessment Programme of the Mediterranean Sea and Coast 

and Related Assessment Criteria 

IUCN – International Union on Conservation of Nature 

LC/LU – land cover/land use 

LEZ – low elevation zone 

NSA – United States National Security Agency 

OSM – OpenStreetMap 

TIF/TIFF – Tagged Image File Format 

UNEP – UN Environment Programme 

WDPA – World Database on Protected Areas 

WGS84 – World Geodetic System 1984 

WKT – well-known text
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1 INTRODUCTION 

This manual provides step-by-step instructions on how to carry out IMAP EO8 Candidate Common 

Indicator 25 “Land cover change” (CCI25) calculation using free and open source (FOSS) software 

and data. 

 

IMAP stands for the Integrated Monitoring and Assessment Programme of the Mediterranean Sea 

and Coast and Related Assessment Criteria that was adopted at the 19th Ordinary Meeting 

(February 2016) of the Contracting Parties (21 Mediterranean country and the European Union) to 

the Barcelona Convention (short for “Convention for the Protection of the Marine Environment and 

the Coastal Region of the Mediterranean”) with the aim to quantitatively and integratively assess 

the status of the Mediterranean sea and coast [1]. IMAP common indicators are the backbone of 

the Barcelona Convention which defines them as [2]: “indicator that summarizes data into a simple, 

standardized, and communicable figure and is ideally applicable in the whole Mediterranean basin, 

or at least on the level of sub-regions, and is monitored by all Contracting Parties”. Currently, there 

are 24 common indicators and 4 candidate common indicators that are developed. IMAP 

(candidate) common indicators are linked to one of 11 Ecological Objectives (EO). Candidate 

common indicators still have some issues that have to be resolved, and one of them is the 

Candidate Common Indicator 25 “Land cover change” (CCI25), which is linked to the EO8 - Coastal 

ecosystems and landscapes. The main aim of the EO8, and consequently of the CCI25, is 

monitoring human activities that are causing “coastal artificialization by sealing the coast with the 

implementation of coastal structures and therefore impact coastal ecosystems and landscapes” 

[2]. 

 

Main steps in CCI25 calculation which are also chapters of this manual are: 

1. preparing software (GIS and spreadsheet application) 

2. acquiring all data that are necessary for CCI25 calculation 

3. preprocessing acquired data 

4. calculating indicator parameters and representing calculation outputs 

 

For each category of input data that are needed for CCI25 calculation, specific data sources were 

used in manual to illustrate processing workflow. Of course, it is possible to use other data sources 

and it is possible they will require some variations in workflow. However, manual should provide 

general instructions for some challenging steps, such as reclassifying initial land cover/land use 

(LC/LU) classes to those required by CCI25 or instructions on how to determine resolution during 

raster clipping. The processing steps should not be performed completely rigorously in line with the 

manual but they can be adapted if needed, as long as they do not have impact on the final 

calculation results. For example, suggested file names in the manual are based on the input data 

that are used in manual, but if other input data are used, file names should reflect that. 
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2 REQUIRED SOFTWARE AND BASIC CONCEPTS 

Software applications that are required for the CCI25 calculation include applications that are 

suitable for managing spatial data, and applications that are designed for working with tabular data 

– spreadsheet applications. 

2.1 GIS application 

Dealing with spatial data (i.e., data that have a location) requires a specialized application from the 

geographic information system (GIS) software domain. One of the most widely used free and open-

source (FOSS) GIS applications is QGIS [3]. Its extensive documentation, supportive and large user 

community, and ability to extend its basic features with many FOSS plugins are the reasons for its 

popularity and why we have decided to use it for CCI25 calculation. QGIS can be downloaded from 

https://www.qgis.org/en/site/forusers/download.html. It is available for Windows, macOS, and 

Linux operating systems. In this manual, we have been using QGIS version 3.22 “Białowieża”, which 

is currently the latest long-term release version. Although CCI255 calculation can be done in other 

QGIS versions, we suggest using this one to avoid problems with differences in user interface and 

algorithm names. 

 

2.1.1 Preparing the QGIS interface and defining basic settings 

After opening QGIS, we can immediately save a new blank QGIS project by going to Project ► 

Save As… and defining the name and location where the QGIS project file (file with QGZ extension) 

will be saved. All algorithms that are available in QGIS cannot be accessed from menus in the top 

menu bar, but rather through the Processing Toolbox panel (highlighted in Figure 2). The Processing 

Toolbox panel can be made visible by clicking on the Processing ► Toolbox (Figure 2). If the 

Figure 1: QGIS logo [2] 

Figure 2: QGIS graphical user interface (Processing Toolbox panel is highlighted) 

https://www.qgis.org/en/site/forusers/download.html
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Processing menu is not available in the QGIS menu bar, the Processing plugin needs to be 

activated: open the Plugins dialog window by going to Plugins ► Manage and install plugins…, click 

on the Installed tab on the left side of the window, and check the box next to the Processing item 

(Figure 3). Also check if the box is ticked next to the GRASS GIS provider plugin and, if it is not, tick 

it. 

To activate (or deactivate) a QGIS toolbar or a panel, you should go to View ► Toolbars or View ► 

Panels and then tick (or untick) ones that are required (or not required). To install, uninstall, 

activate, or deactivate plugins, go to Plugins ► Manage and install plugins… The plugin that should 

be installed is the “QuickMapServices” plugin. To install it, while in the All tab of the Plugins dialog 

window, enter “QuickMapService” in the search bar on top, select the QuickMapServices plugin 

from the list and click the Install Plugin button (Figure 4). Repeat the same procedure for the “Shape 

Tools” plugin. The Shape Tools plugin enables conducting calculations on the surface of the 

ellipsoid and is developed by the United States National Security Agency (NSA). 

QuickMapService plugin enables loading many basemaps in the current QGIS project. After installing it, 

it is possible to load new basemaps by going to Web ► QuickMapServices and choosing one of the 

basemaps that are grouped by its producers. Figure 5 shows how to add OpenStreetMap (OSM) 

Standard map to the QGIS project (highlighted with red rectangles). It is possible to load multiple 

basemaps in the QGIS project. After clicking on one of the basemaps, that basemap is being loaded 

into the QGIS project and listed in the Layers panel (Figure 6). Only some basemaps are listed under 

Web ► QuickMapServices, and to search all available basemaps, click on Web ► QuickMapServices 

Figure 3: Activating Processing plugin 

Figure 4: Installing the “QuickMapServices” plugin 
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► Search QMS, and in the new Search QMS panel that opens, search by entering keywords in the 

search bar (Figure 5, blue rectangles), or by filtering basemaps based on availability in the currently 

zoomed-in location (click on the Filter by extent button). When using basemaps from the 

QuickMapServices plugin, always carefully check the terms of use, and make sure to appropriately 

attribute the source of a particular basemap. 

Since we will be using only the basic algorithms that are already well established, there should not 

be any problems with different versions of corresponding libraries. If you want to be completely sure 

that all versions in your QGIS installation are in line with the versions used for this manual, you can 

go to Help ► About and compare versions: QGIS version: 3.22.10; GDAL/OGR version: 3.5.1; PROJ 

version: 9.0.1; EPSG Registry database version: v10.064 (2022-05-19); GEOS version: 3.10.3-

Figure 5: Adding OpenStreetMap (OSM) Standard basemap with the QuickMapServices plugin 

Figure 6: OpenStreetMap standard basemap loaded in QGIS project and listed in the Layers panel 

(© OpenStreetMap contributors) 
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CAPI-1.16.1; SQLite version: 3.38.1; SpatiaLite version: 5.0.1; grassprovider version: 2.12.99; and 

processing version: 2.12.99. 

2.1.2 Calculating area in (Q)GIS 

The most important results of CCI25 calculations carried out in GIS applications are areas of 

different land cover/land use (LC/LU) classes. Area calculations in GIS present a special problem 

posed by the complexity that is caused by the curvature of the Earth’s surface. Curved Earth’s 

surface cannot be transformed on a flat surface of a map or a screen on some device without 

deformation. This has to be kept in mind during area calculations in GIS. Firstly, points from the 

Earth’s surface, which is complex and ever-changing, are being projected on the surface of ellipsoid 

or spheroid, fairly simple mathematically defined surfaces. At this point, the location of each point 

is defined in ellipsoidal or spherical coordinates (latitude and longitude). This type of coordinate 

reference system (CRS) is in QGIS called a “geographic coordinate system”. Secondly, the 

coordinates of these points are being projected from the ellipsoid or sphere to coordinates on the 

flat surface by a set of formulas that are defined by the so-called cartographic projection. A flat 

surface in this sense is called a cartographic projection plane, and in QGIS these coordinate 

systems are referred to as “projected coordinate systems”. This second step, which produces the 

so-called projected coordinates, is not required, and very often positions in GIS datasets are given 

in ellipsoidal or spherical coordinates. If location is nevertheless given in projected coordinates, 

and area needs to be calculated based on those coordinates, it should be ensured that cartographic 

projection preserves the ratio of the area between points on the ellipsoid and corresponding points 

in the cartographic projection plane. A special group of that kind of projections is called equal-area 

projections. Finally, in QGIS and some other GIS applications, there are two approaches when 

calculating area: 

1. ensure that all data is being referenced in the projected coordinate system based on equal-

area projection, and then make area calculations using projected coordinates 

2. make all area calculations on the surface of the ellipsoid or spheroid, using ellipsoidal or 

spherical coordinates 

We suggest the second approach since it simplifies and increases the accuracy of area calculation 

by avoiding the complexity of choosing the right cartographic projection and problems that arise 

from raster data reprojection. We acknowledge that both of these approaches have a drawback: 

areas that are being calculated are not areas on the Earth’s surface. Ellipsoid or spheroid cannot 

perfectly fit Earth’s surface, and this misalignment inevitably produces differences between the 

area on the Earth’s surface and the corresponding projected area on the ellipsoid or spheroid. The 

larger the height difference between the Earth’s surface and the ellipsoid or spheroid, the larger 

the area difference. All data in the same region will be similarly affected by this error, so the final 

percentages that have to be calculated will not be significantly degraded. Currently, in QGIS (and 

other GIS applications) there is no better straightforward solution. 

 

To be sure that area calculations will be carried out on the surface of the ellipsoid or spheroid, 

rather than cartographic projection plane by using projected coordinates, go to Project ► 

Properties… and then in the General tab define suitable ellipsoid in Ellipsoid (for distance and area 

calculations) dropdown (Figure 7, as explained in [4]). We suggest using WGS84 (EPSG:7030) since 

the data we will be using are referenced using that ellipsoid. Also, make sure that Units for distance 

measurement and Units for area measurement are set to the desired unit. 

 

However, GIS expert could decide to transform data from geographic to projected CRS before 

conducting calculations. If so, in calculation report it should be explicitly stated what was the 

transformation/reprojection procedure, especially for raster data (resampling method, target pixel 

size, etc.). 
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2.1.3 Choosing a coordinate reference system (CRS) 

As already discussed in the previous section, choosing the right coordinate reference system (CRS) 

has to be done carefully. Since settings for area calculations should have already been applied in 

QGIS project properties (section 2.1.2), here we will focus on choosing CRS that is suitable for data 

visualization. For visualization purposes, it is common to choose a CRS from a group of projected 

coordinate systems in QGIS. CRS can be defined on a QGIS project-level by going to Project ► 

Properties…, and then choosing desired CRS in the CRS tab. In Figure 8, ETRS89/LAEA Europe CRS 

is chosen for project-level CRS (EPSG code is 3035 [5], written as “EPSG:3035”), which is a good 

choice when the whole of Europe has to be visualized. In Figure 8, EPSG:3035 CRS is filtered from 

the list of all available CRSs by entering “3035” in the Filter field. Now all data that will be imported 

in QGIS will be “on-the-fly” reprojected to this CRS, even if they are originally georeferenced/stored in 

different CRSs. It is important to understand that by changing project-level CRS, data are only 

temporary, for visualization purposes being “on-the-fly” reprojected to defined CRS, and after closing 

QGIS, all data remain stored in their original CRSs. For deciding which CRS is the most suitable for a 

Figure 7: Setting the suitable ellipsoid for distance and area calculations in QGIS 

Figure 8: Defining project-level CRS in QGIS project properties 
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particular area, we suggest consulting Esri’s Quick Notes on Map Projections in ArcGIS [6], the United 

States Geological Survey (USGS) map projections poster [7], or using the web app for interactive 

choosing the most suitable projection which is available at https://projectionwizard.org (Figure 9). 

After defining project-level CRS, in the bottom right corner, in the status bar in QGIS, the EPSG code 

of the chosen CRS is shown (visible in Figure 14). 

 

When changing CRSs, sometimes there are multiple ways of transforming coordinates between them. 

In those cases, QGIS asks a user to choose one of the applicable transformations (Figure 10). Mostly, 

as in this case, QGIS already chooses the best available transformation, and it is only needed to click 

on the OK button. 

In case you want to use the projected coordinate system defined at https://projectionwizard.org  that 

is not one of the predefined CRSs with EPSG code, click on the WKT (well-known text) link (highlighted 

in Figure 9) and copy text from the pop-up. In QGIS, go to Settings ► Custom Projection… and in a 

new dialog window (Figure 11) click on the  button marked with ❶ in Figure 11, under 

Name define the name for the new CRS (❷ in Figure 11), in the Format dropdown choose “WKT” 

(❸ in Figure 11), paste copied text from the https://projectionwizard.org in the Parameters field 

Figure 10: Choosing the most suitable/accurate transformation between CRSs 

Figure 9: Defining properties of projected coordinate system at https://projectionwizard.org 

https://projectionwizard.org/
https://projectionwizard.org/
https://projectionwizard.org/
https://projectionwizard.org/
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(❹ in Figure 11) and click the OK button. This new CRS will now be shown on the list of all available 

CRS in QGIS. It will be listed under the User Defined Coordinate Systems group, and it can be found 

by entering its name in the Filter field (Figure 8). 

2.1.4 Common data formats used in GIS applications 

The most commonly used data formats in GIS applications can be divided into raster and vector 

formats. Data that are stored in raster and vector data formats are regularly referred to as raster 

and vector data, or, when imported in GIS application, raster and vector layers. Some raster and 

vector data formats store data from a single layer in only one file, and some in multiple files. 

 

Simply said, raster data are in form of matrix or a raster, each matrix element has a value and is 

called a pixel. Each pixel, which is regularly a rectangle, has an indirectly assigned location (i.e., 

coordinates in some CRS) through coordinates that are assigned to pixels in the corners of the 

matrix and dimensions of each pixel, which are constant in the whole raster. Raster data are in GIS 

applications commonly used to represent some spatial property that has a value in every point in 

space, for example, height above sea level, temperature, etc., but they can also be used to 

represent some discrete objects in space, such as roads, buildings and so on. Raster data format 

that will be mostly used throughout this manual is TIF (or TIFF), or more precisely, its extension, 

GeoTIFF (TIF/TIFF file with embedded information that assign location to the raster and then 

indirectly to every pixel). 

 

Plainly speaking, in vector data formats, spatial features/objects are stored as points that are 

defined by their coordinates in some CRS, lines that are defined by points, and polygons that are 

defined by lines. Ultimately, vector data are based on coordinates of points and accompanying data 

that define which points are just points, and which are forming lines or polygons. Some data formats 

allow storing only one type (point, line, or polygon) at a time. Different types of information can be 

stored along with each feature (each point, line, or polygon) and are called attribute values. 

Attribute values are stored in the so-called attribute table in which each row corresponds to one 

feature (point, line or polygon), and each column/filed to one attribute. Vector formats are 

commonly used to represent discrete features, but are also sometimes used to represent spatially 

continuous features (for example, land cover). Vector data formats that will be used in this manual 

are Esri shapefile format, GeoPackage (GPKG), and GeoJSON. Esri shapefile format for a single 

Figure 11: Defining custom CRS 
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vector layer consists of at least three files with extensions SHP, SHX, and DBF, while GeoPackage 

and GeoJSON formats store all information from one layer in a single file. Visual difference between 

vector layer with polygonal features and raster layer that both represent land cover over same area 

are visible in Figure 12. 

 

One important fact that should always be kept in mind while working with QGIS is that in QGZ project 

file no raster or vector data are stored. QGZ project file stores only, among some other things, 

locations of raster and vector data storage location. By default settings, always be sure to keep 

relative location between the QGZ project file and corresponding files of imported raster and vector 

layers unchanged. 

2.2 Spreadsheet application 

Results of spatial analysis conducted in QGIS need to be exported in tabular form and then further 

analyzed in a spreadsheet application. Any spreadsheet application is suitable for making basic 

calculations, like proprietary Microsoft Excel [8], free and open-source LibreOffice Calc [9], or even 

web-based applications like Google Sheets [10]. It is possible that some of these applications will 

not support some of the more advanced analyses or graphical representations of calculated data. 

  

Figure 12: Visual difference between polygonal vector (left) and raster (right) data representing land cover 

over same area 



 

10 

3 ACQUIRING AND PREPARING DATA 

This chapter focuses on acquiring and importing all relevant data in QGIS and then preparing them 

for conducting spatial analysis. In the following sections, file names that are being used in QGIS will 

be typed in italic style if they can be treated as temporary files, and in italic bold style if it is advisable 

to store them permanently. Of course, mentioned file names are just suggestions, and you can use 

any file names you like. 

 

Main preparation steps include: 

1. defining the area of interest (AOI) 

2. downloading required data 

3. creating coastal strips and reporting units 

4. preparing LC/LU and elevation data and data on protected areas for CCI25 calculation 

 

3.1 Defining the area of interest (AOI) 

Area of interest (AOI) should be defined as a polygon vector layer with one polygon. To create a new 

GeoPackage [11] vector layer: 

1. go to Layer ► Create Layer ► New GeoPackage Layer… (Figure 13) 

2. by clicking on the three-dots-button (❶ in Figure 13), define the name (you can use 

aoi.gpkg) and path on the disc where the new GeoPackage (GPKG) file will be stored 

3. in the Geometry type dropdown select Polygon (❷ in Figure 13) 

4. select the desired CRS (we suggest selecting WGS84 (EPSG:4326) – ❸ in Figure 13; if 

desired CRS is not listed, then by clicking on the button marked with ❹ in Figure 13, select 

desired CRS from the list of all available CRSs in QGIS) 

5. finally, click on the OK button (❺ in Figure 13) 

 

Figure 13: Creating a new GeoPackage vector layer (basemap: ©OpenStreetMap contributors) 
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The newly created GeoPackage layer will automatically be loaded into the QGIS and listed in the 

Layers panel (Figure 14). To add a new polygon in a GPKG vector layer, follow these steps: 

1. toggle (i.e., enable) editing of GPKG layer (aoi.gpkg) by right-clicking on the layer name in 

the Layers panel, and then clicking on Toggle Editing (Figure 14) 

2. if you did not already, add one of the basemaps using the QuickMapServices plugin (it can 

be OpenStreetMap: Web ► QuickMapServices ► OSM ► Standard, as shown in Figure 5), 

and zoom (by scrolling the mouse wheel) and pan (by moving the mouse while mouse wheel 

is pressed) map to the AOI 

3. while the AOI layer is selected in the Layers panel, go to Edit ► Add Polygon Feature or click 

on the icon marked with ❶ in Figure 15 (it is a part of the Digitizing toolbar) 

Figure 14: After clicking on the Toggle Editing, new features can be added, or existing features can be 

modified or deleted from a vector layer (basemap: ©OpenStreetMap contributors) 

Figure 15: Creating a new polygon in a vector layer (basemap: ©OpenStreetMap contributors) 
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4. on the map, with left mouse clicks, encircle a polygonal AOI that contains an area for which 

CCI25 has to be calculated (points that define polygonal AOI do not need to be densely 

spaced and it is a good practice to encircle a little bit wider area to be sure that you have 

included the whole AOI, example for Italy is shown on Figure 15, marked with ❷) 

5. finish polygonal AOI definition by right mouse click (right mouse click will not add a new point) 

6. click the OK button in a new dialog window (❸ in Figure 15) 

7. save changes in the AOI vector layer by right-clicking on its name in the Layers panel, then 

clicking on the Save Layer Edits (❸ in Figure 15), and then again on Toggle Editing (❹ in 

Figure 15) to lock the layer from further edits 

This AOI polygon in aoi.gpkg file will be used to clip input layers with the main purpose to speed up 

the processing by limiting calculations to its extent. 

 

Metadata and settings for each layer in QGIS can be accessed by right clicking on the layer name 

in the Layers panel, and then clicking on Properties… (visible in Figure 14), or, by default settings, 

by double-click on the layer name in the Layers panel. If you double-click on the aoi.gpkg layer in 

the Layers panel, the Layer Properties window that is shown on Figure 16 will open. Layer Properties 

window that is shown in Figure 16 list options for vector layer. On the left side of the window, there 

are different tabs. In the Information tab, you can read data format that is used for storing data, 

path on the computer storage where data is stored, CRS that is used to georeference data and 

some other metadata. In the Source tab, you can again see CRS information, you can build spatial 

index (it is always advisable to build spatial index if it is not already, by clicking on the Create Spatial 

Index button), and define query that will be used to filter features in vector layer based on their 

attributes values. In the Symbology tab, you can define different options for visualization of data 

stored in each layer. In the Labels tab, you can define setting for showing attribute values in the 

QGIS map view, and in the Fields tab you can edit, add, or delete fields/attributes from the attribute 

table. 

To open an attribute table for a vector layer, right click on the layer name in the Layers panel and 

click on the Open Attribute Table (visible in Figure 14). If you open attribute table for the aoi.gpkg 

layer, a new window, which is visible in Figure 17, will open. Since aoi.gpkg layer has only one 

polygon feature, attribute table has only one row. 

 

Figure 16: The Layer Properties window with the Symbology tab opened 
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3.2 Downloading required data 

Data that have to be downloaded for CCI25 calculation are: 

1. Land cover/land use (LC/LU) data 

2. Elevation data 

3. Coastline data 

4. Administrative units data 

5. Data on protected areas 

3.2.1 Land cover/land use (LC/LU) data 

As stated in [18], ESA WorldCover Project Land cover (ESA WCP) is proposed as a source for LC/LU 

data and specifically land cover data for the year 2021 is proposed to be used for the calculation 

of the baseline data for CCI25. ESA WCP rasters can be downloaded from https://viewer.esa-

worldcover.org/worldcover/ by following these steps: 

1. register and login 

2. zoom to the area of interest 

3. click on the “Layers” in the vertical menu and select WorldCover V2 2021 layer (Figure 18)  

4. click on the “Download” in the vertical menu bar (Figure 18) 

5. in a new window that pops up (Figure 19), on which is a list of 3°×3° ESA WCP tiles that 

fully or partly overlaps with the zoomed area, select tiles for download and then click Next 

6. in a new window that pops up (Figure 20), click Download 

Figure 17: Attribute table for a vector layer 

Figure 18: Download link in vertical menu bar of the ESA WCP viewer 

https://viewer.esa-worldcover.org/worldcover/
https://viewer.esa-worldcover.org/worldcover/
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Along with land cover data, the service offers a download of data with a quality description. ESA 

WCP tiles are 3°×3° GeoTIFF raster tiles with a spatial resolution (i.e. pixel dimension on ellipsoid 

that is used to approximate the Earth’s surface) of 1°/12008 [13]. This resolution corresponds to 

approximately 10 m at equator for the Map product. ESA WCP raster tiles are georeferenced in the 

geographic coordinate system WGS84 (EPSG:4326). ESA WCP terms of use are defined in the 

Product User Manual [13]. 

 

3.2.2 Elevation data 

FABDEM (Forest and Buildings removed Copernicus DEM) elevation data for non-commercial usage 

(CC BY-NC-SA 4.0 license) can be downloaded from https://data.bris.ac.uk/data/dataset/ 

25wfy0f9ukoge2gs7a5mqpq2j7 (Figure 21) by clicking on one of the ZIP archives containing raster 

elevation data. 

Figure 19: ESA WCP tiles (3°×3°) 

Figure 20: ESA WCP download window 

https://data.bris.ac.uk/data/dataset/25wfy0f9ukoge2gs7a5mqpq2j7
https://data.bris.ac.uk/data/dataset/25wfy0f9ukoge2gs7a5mqpq2j7
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Selecting the correct ZIP file for downloading might be problematic since there is no map where the 

coverage of each ZIP file is visible. The coverage of each ZIP file has to be read from the ZIP archive 

name. For example, if the ZIP archive name starts with “N40E060-N50E070”, it corresponds to the 

tile that covers an area from 40° to 50° north latitude and from 60° to 70° east longitude. Using 

a map with a 10-degree graticule grid available at https://maps.princeton.edu/catalog/stanford-

fr122tq8910 might help determine which tile(s) overlaps with the AOI. Each ZIP archive contains 

multiple (up to 100) raster tiles that cover 10°×10° of the Earth’s surface. Each raster tile covers 

1°×1° and can be visualized by going to https://panda.copernicus.eu/web/cds-catalogue/panda 

and following steps 1-2-3 from Figure 22. Make sure to download all ZIP files that contain elevation 

data that intersect the AOI. 

 

Figure 21: Screenshot of the website from which it is possible to download FABDEM raster data 

Figure 22: Steps for visualizing 1°×1° Copernicus DEM tiles 

https://maps.princeton.edu/catalog/stanford-fr122tq8910
https://maps.princeton.edu/catalog/stanford-fr122tq8910
https://panda.copernicus.eu/web/cds-catalogue/panda
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This elevation data is a digital elevation model (DEM) called FABDEM (Forest and Buildings removed 

Copernicus DEM)  which is produced from Copernicus DEM [14] by removing heights of buildings 

and forests and making some other adjustments. As reported by its authors, FABDEM has 

significantly better accuracy in comparison to other global “freely available” DEMs [15]. Each 

FABDEM raster tile is georeferenced in the geographic coordinate system WGS84 (EPSG:4326) 

with a spatial resolution (pixel dimension) in the north-south direction of 1/3600° [16], which is 

around 30 m. Heights are referenced in Earth Gravitational Model 2008 (EGM08, EPSG:3855 [16]). 

 

If elevation data will be commercially used, then Copernicus DEM GLO-30 should be chosen instead 

of FABDEM. It can be downloaded by following steps described on https://spacedata.copernicus.eu/ 

web/cscda/data-access. 

3.2.3 Coastline data 

According to [12], official coastline data is proposed to be used for CCI25 calculation. If official data 

are not available, or if they are not dense enough or are outdated, then coastline data can be 

extracted from the OpenStreetMap (OSM) data [17]. Although OSM data are not official and are 

crowdsourced, our experience shows that OSM coastline data are highly reliable and up-to-date. 

OSM coastline data can be downloaded from https://osmdata.openstreetmap.de/ 

data/coastlines.html. There are two download options that differ in CRS that is used to 

georeference the data. We suggest downloading data from the first option that uses WGS84 

(EPSG:4326) as a CRS (highlighted in Figure 23). This coastline data is stored in Esri shapefile 

linestring vector format. Terms of use are available at https://www.openstreetmap.org/copyright. 

 

Coastline is a baseline for defining a 10-km coastal zone that is needed for constructing CCI25 

reporting units. In some areas, especially those where the coast is flat and the intertidal zone is 

wide, coastlines extracted from different datasets can vary significantly. This is especially 

problematic when there is a discrepancy between the coastline that is used for generating coastal 

strips (vector) and the coastline that can be extracted from the LCLU dataset (raster). These 

discrepancies can lead to omission or commission errors in specific land cover class area for 

Figure 23: Downloading OSM coastline data from 

https://osmdata.openstreetmap.de/data/coastlines.html 

https://spacedata.copernicus.eu/web/cscda/data-access
https://spacedata.copernicus.eu/web/cscda/data-access
https://osmdata.openstreetmap.de/data/coastlines.html
https://osmdata.openstreetmap.de/data/coastlines.html
https://www.openstreetmap.org/copyright
https://osmdata.openstreetmap.de/data/coastlines.html
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specific reporting units. Thus, GIS expert should perform visula inspection of areas along the 

coastline and highligh the reporting units in the calculation report for which this issue has an 

impact. 

 

3.2.4 Administrative units data 

The CCI25 indicator guidance factsheet [18] suggests using coastal administrative units 

(cities/municipalities) as the lowest level of authority responsible for development of spatial/urban 

plans and managing coast. According to [12], it is suggested to use national official data on 

administrative units if they are available. If not, OSM administrative units data can be downloaded 

from https://osm-boundaries.com/Map by following these steps: 

1. if you do not already have one, create a new OpenStreetMap account by going to 

https://www.openstreetmap.org and filling out the form that is available after clicking on 

the “Sign Up” button in the upper right corner (Figure 24) 

2. go to https://osm-boundaries.com/Map and after clicking on the “Authenticate” button in 

the top right corner (marked with ❶ on Figure 25), and again the “Authenticate” button in 

a new modal window (❷ in Figure 25), you will be redirected to the https://www. 

openstreetmap.org/ where you need to enter your OpenStreetMap account data (previously 

created username and password or the ones you already had) and after logging in authorize 

OSM-boundaries to access your OSM account by clicking on the “Grant Access” button 

(❸ on Figure 25) 

3. find out which “OSM admin level” (the encircled number before the administrative unit 

name in the list on the left side – marked with ❹ in Figure 25) is equivalent to the units in 

the project area responsible for development of spatial/urban plans and managing coast. 

4. click on the “Download” button (marked with ❺ in Figure 25) 

5. in a new modal window (Figure 26) in a dropdown marked with ❻ in Figure 26 select the 

country for which you want to download administrative units data, in both dropdowns marked 

with ❼ select the same “OSM admin level” that was determined in step 3, switch from 

“Include water” to “Land only” (marked with ❽), and finally click on the “Download” button 

that is marked with ❾ on Figure 26 (all other options may remain unchanged) 

Figure 24: Initiate the creation of a new OpenStreetMap account by clicking on the “Sign Up” button 

https://osm-boundaries.com/Map
https://www.openstreetmap.org/
https://osm-boundaries.com/Map
https://www.openstreetmap.org/
https://www.openstreetmap.org/
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If only options from step 5 have been changed in the modal window shown in Figure 26, and all 

others remained unchanged, clicking on the “Download” button will initiate the download of OSM 

administrative data stored in GeoJSON vector polygon format (actually a compressed .geojson.gz 

file) that is georeferenced in WGS84 CRS (EPSG:4326). Terms of use are available at 

https://www.openstreetmap.org/copyright. 

 

 
When OSM data are used as a source for administrative units, data should be validated by 

comparison with national official data and visual inspection by expert that is conducting 

calculations. Even if national official data are outdated, they can still be used as an assistance in 

validation. Additionaly, expert should check if coastline used for generating coastal strips is 

matching the coastline from the administrative units data. If not, coastline part of administrative 

boundaries should be replaced with the coastlines of coastal strips.  

Figure 26: Setting options for downloading OSM administrative units data 

Figure 25: Downloading OSM administrative units data from the https://osm-boundaries.com/Map 

https://www.openstreetmap.org/copyright
https://osm-boundaries.com/Map


 

19 

3.2.5 Data on protected areas 

Locations and boundaries of terrestrial and marine protected areas can be obtained from the World 

Database on Protected Areas (WDPA) available for non-commercial use on Protected Planet 

websites (https://www.protectedplanet.net). WDPA is a UN Environment Programme (UNEP) and 

International Union on Conservation of Nature (IUCN) project, it is being created in collaboration 

with governments, non-governmental organizations, academic institutions, and industry 

representatives [21]. WDPA is being updated every month. 

 

The most current WDPA dataset can be downloaded from https://www.protectedplanet.net by 

following these steps: 

1. in the “Thematic Areas” dropdown (marked with ❶ in Figure 27) in the top menu bar, click 

on the “Protected Areas (WDPA)” (❷ in Figure 27) 

2. on the new web page, to download the whole WDPA dataset, click on the “Download” button 

(marked with ❸ in Figure 28), and to download only a portion of data, which we suggest, 

click on the “Explore Protected Areas” button (❸ in Figure 28) 

Figure 28: To filter the WDPA protected areas by country, click on the “Explore Protected Areas” button 

Figure 27: Accessing the WDPA web page on the Protected Planet website 

https://www.protectedplanet.net/
https://www.protectedplanet.net/
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3. after clicking on the “Explore Protected Areas” button (❸ in Figure 28), on a new webpage 

(Figure 29), it is possible to filter the WDPA protected areas based on region (continental 

scale), country, or to search for a specific protected area; to filter WDPA protected areas 

within a single country, click on “Countries” (❹ in Figure 29), enter a name of the country 

in the field marked with ❺, press Enter, and click on the country card (❻ in Figure 29) 

4. after clicking on the country card (❻ in Figure 29), a new webpage with map and statistics 

for the selected country opens, and on it, click on the “Download” button (❼ in Figure 30) 

5. after clicking on the “Download” button, a couple of options are shown, we suggest 

choosing the “SHP” one (❽ in Figure 30), which will after clicking on the “Continue” button 

in the new modal window (❾ in Figure 30), prepare data for download in Esri shapefile 

vector format 

6. finally, to download prepared WDPA, click on the “Download” button in the bottom right 

corner (❿ in Figure 30) 

Figure 29: Filtering the WDPA protected areas by country 

Figure 30: Downloading country-filtered WDPA data on protected areas 
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Clicking on this “Download” button will initiate downloading of a ZIP archive that contains WDPA 

data on protected areas stored in Esri shapefile polygon and point vector format. Data are 

georeferenced in WGS84 (EPSG:4326) CRS. Terms of use are available at https://www. 

protectedplanet.net/en/legal, and attribution is also specified above the “Download” button 

marked with ❿ in Figure 30. 

 

If WDPA data will be commercially used, then data should be obtained from the Integrated 

Biodiversity Assessment Tool (IBAT) website: https://www.ibat-alliance.org/.  

 

3.3 Creating coastal strips and reporting units 

So far, in QGIS we have OSM basemap and GPKG vector layer with the polygonal area of interest 

(aoi.gpkg). For constructing coastal strips and reporting units, the following datasets are required: 

coastline data and administrative units data. All directions and suggestions in the following sections 

and chapters of this manual that require defining options in dialog windows within QGIS are limited 

only to those parts that are required to be changed. All other options that are not mentioned should 

be left in their default state. 

 

Three coastal strips have to be constructed as inland zones that are 0 – 100 m, 300 – 1000 m, 

and 1 – 10 km away from the coastline. Since QGIS does not natively support creating the so-called 

geodesic buffer zones (what is a straight line between two points in a plane, is a geodesic between 

two points on a surface of the ellipsoid – path with the shortest distance) and all downloaded data 

are in the geographic coordinate system EPSG:4326, we will need the Shape Tools plugin 

(installation procedure is explained in section 2.1). To construct coastal strips and reporting units, 

we suggest the following workflow (some of these steps (especially step 6) are computationally 

expensive, so be prepared for a longer processing time): 

7. although not necessary, unzip the downloaded ZIP file with the coastline data (originally 

named coastlines-split-4326.zip), import the Esri shapefile in QGIS by going to Layer ► Add 

Layer ► Add Vector Layer…, and then after clicking on the three-dots-button in a new dialog 

window (❶ in Figure 31) locate lines.shp file in the folder created after unzipping (as 

Figure 31: Importing coastline data in QGIS 

https://www.protectedplanet.net/en/legal
https://www.protectedplanet.net/en/legal
https://www.ibat-alliance.org/
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already mentioned, one Esri shapefile consists of at least three files that have SHP, SHX, 

and DBF extension), and import it by clicking on the Add button (❷ in Figure 31) 

8. create a spatial index for the imported layer with coastline data (lines.shp), which will, under 

some circumstances, speed up processing done with this layer: 

a. go to Vector ► Data Management Tools ► Create Spatial Index… 

b. in a new dialog window (Figure 32), under the Input layer dropdown (❶ in Figure 

32) choose the imported coastline data layer (lines.shp) 

c. click the Run button (❷ in Figure 32; this operation does not create a new layer, 

but only adds a spatial index to the existing one – for Esri shapefile format it creates 

a new file with QIX extension in the same location on the disc as other files that 

compose corresponding Esri shapefile layer) 

9. clip the imported coastline data layer (lines.shp) with the AOI layer (aoi.gpkg): 

a. go to Vector ► Geoprocessing Tools ► Clip… 

b. in a new dialog window (Figure 33), under the Input layer dropdown (marked with 

❶ in Figure 33), choose the imported layer with coastline data (lines.shp) 

c. in the Overlay layer dropdown choose the vector layer in which the area of interest 

is defined (aoi.gpkg) – marked with ❷ in Figure 33  

d. after clicking on the three-dots-button (❸ in Figure 33) and choosing Save as File…, 

define storage location, name the output clipped coastline file with coastline-aoi, 

Figure 33: Clipping coastline data to the extent of the AOI 

Figure 32: Creating spatial index for vector layer 
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and choose GPKG as filetype (output file will be named coastline-aoi.gpkg), as 

shown on Figure 34 

e. although it should already be ticked, if it is not, always tick the Open output file after 

running algorithm option to load the output layer into QGIS after algorithm finishes 

with processing (❹ in Figure 33) 

f. click the Run button to start the clipping algorithm (❺ in Figure 33) 

10. densify line vertices in the previously created layer (coastline-aoi.gpkg): 

a. go to Vector ► Shape Tools ► Geodesic shape densifier 

b. in a new dialog window (Figure 35), under the Input layer dropdown (marked with 

❶ in Figure 35) choose the previously created layer with coastline data clipped to 

the area of interest (coastline-aoi.gpkg) 

c. for Maximum line segment length (in kilometers) enter 0.02 (❷ in Figure 35), and 

be sure you are using the right decimal separator (point or comma) which can be 

checked by going to Settings ► Options, in the General tab on the left side, under 

“Sample data: (…) float:” 

d. after clicking on the three-dots-button (❸ in Figure 35) and choosing Save as File…, 

define the name and storage location for densified coastline (use coastline-aoi-

densified.gpkg, choose GPKG as filetype) 

e. click the Run button to start the densifying algorithm (❺ in Figure 35) 

11. extract vertices from the densified coastline GPKG layer (result for Italy is visible on Figure 

37, point coloring will most certainly be different): 

Figure 34: Defining file name and file type when saving a new file (under Windows operating system) 

Figure 35: Densifying vertices in coastline data 



 

24 

a. go to Vector ► Geometry Tools ► Extract vertices… 

b. in a new dialog window (Figure 36), under the Input layer dropdown (marked with 

❶ in Figure 36) choose the previously created layer with densified coastline 

vertices (coastline-aoi-densified.gpkg) 

c. after clicking on the three-dots-button (❷ in Figure 36) and choosing Save as File…,  

define the name and storage location for the output point layer (for name, use 

coastline-vertices.gpkg, choose GPKG as filetype) 

d. click the Run button to start the algorithm (❹ in Figure 36) 

12. create three buffers (300 m, 1 km, and 10 km) around each extracted vertex in the 

coastline-vertices.gpkg layer: 

a. go to Vector ► Shape Tools ► Create shape ► Create ellipse, and click on the Run 

as Batch Process button in the new dialog window (highlighted in Figure 38) 

b. click twice on the  button that is marked with ❶ in Figure 39 

c. in all three dropdowns highlighted with ❷ in Figure 39 select the coastline-

vertices.gpkg as an Input layer 

d. for Shape type select “Polygon” (❸ in Figure 39) 

e. for the Semi-major axis and Semi-minor axis enter values as shown in Figure 39 

(the first is 300, the second is 1000, and the third is 10000 – marked with ❹) 

f. for Radius units select “Meters” (❺ in Figure 39) 

Figure 36: Extracting vertices from the densified coastline data 

Figure 37: Extracted vertices from the densified coastline data (example for Italy) 
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g. for the Number of drawing segments (approximate) enter 64 (❻ in Figure 39) 

h. in the Output layer column (marked with ❼ in Figure 40), define names and storage 

locations for output buffer layers (for names, use buffer-300m.gpkg, buffer-

1km.gpkg, and buffer-10km.gpkg, choose GPKG as filetype) by clicking on the 

corresponding three-dots-buttons while taking care that layer names correspond to 

Semi-major axis and Semi-minor axis values (marked with ❹ in Figure 39) 

i. tick the Load layers on completion option (❽ in Figure 40) 

j. finally, click the Run button to start buffer creation (❾ in Figure 40) 

 

Figure 38: Switching from single-processing to batch-processing point buffer creation 

Figure 39: Creating 300 m, 1 km, and 10 km buffers around every extracted vertex from the densified 

coastline data (1) 

Figure 40: Creating 300 m, 1 km, and 10 km buffers around every extracted vertex from the densified 

coastline data (2) 
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13. dissolve 300 m, 1 km, and 10 km buffers: 

a. go to Vector ► Geoprocessing Tools ► Dissolve…, and click on the Run as Batch 

Process button in the new dialog window (highlighted in Figure 41) 

b. click twice on the   button that is marked with ❶ in Figure 42 

c. in the Input layer column (marked with ❷ in Figure 42), select three previously 

created buffer layers (buffer-300m.gpkg, buffer-1km.gpkg, and buffer-10km.gpkg) 

d. in the Dissolved column, for each layer click on the three-dots-button and define the 

name and storage location for each layer (for name, use buffer-300m-dissoved.gpkg, 

buffer-1km-dissolved.gpkg, and buffer-10km-dissolved.gpkg, choose GPKG as 

filetype) while taking care that layer names in the Input layer column correspond to 

names in the Dissolved column (marked with ❸ in Figure 42) 

e. tick the “Load layers on completion” option (❹ in Figure 42) 

f. finally, click the Run button to start the dissolving algorithm (❺ in Figure 42) 

14. create spatial differences from previously created dissolved buffers to generate 

300 – 1000 m and 1 – 10 km strips: 

a. go to Vector ► Geoprocessing Tools ► Difference… and click on the Run as Batch 

Process button in the new dialog window (highlighted in Figure 43) 

b. click once on the  button that is marked with ❶ in Figure 44 

c. if in dropdowns in the Input layer and Overlay layer columns you choose the same 

layers as in Figure 44 (marked with ❷), the upper command will produce a 

300 – 1000 m coastal strip, and lower a 1 – 10 km one 

d. in the Difference column (❸ in Figure 44), define names and storage location for 

each output layer by clicking on three-dot-buttons (name upper layer with strip_300-

1000m.gpkg and lower with strip_1-10km.gpkg, choose GPKG as filetype) 

Figure 41: Switching from single-processing to batch-processing dissolving 

Figure 42: Dissolving 300 m, 1 km, and 10 km buffers 
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e. tick the “Load layers on completion” option (❹ in Figure 44) 

f. finally, click the Run button to start the creation of the spatial difference layer (❺ in 

Figure 44) 

15. merge two layers created in the previous step (strip_300-1000m.gpkg and strip_1-

10km.gpkg) and dissolved 300 m buffer from step 7 (layer buffer-300m-dissolved.gpkg): 

a. go to Vector ► Data Management Tools ► Merge vector layers… 

b. in a new dialog window (Figure 45) click on the three-dots-button (marked with ❶) 

c. in a new window (Figure 46) tick three layers that have to be merged (strip_300-

1000m.gpkg, strip_1-10km.gpkg, and buffer-300m-dissolved.gpkg, as is marked 

with ❷ in Figure 46) and click the OK button (marked with ❸ in Figure 46) 

d. define a storage location and name for the output layer by clicking on the three-

dots-button marked with ❹ on Figure 45 and choosing Save as File… (name it with 

coastal-strips.gpkg) 

e. finally, click the Run button to start merging layers (marked with ❺ in Figure 45) 

16. import administrative units data downloaded from OSM-boundary (.geojson.gz file, the 

filename is starting with “OSMB”) in QGIS by going to Layer ► Add Layer ► Add Vector 

Layer… and then follow the same steps as when importing coastline data (Figure 31), or 

just drag&drop downloaded file into QGIS (after importing administrative units, map view in 

QGIS should look like the one on Figure 47; if needed, draw order of different layers could 

be changed by changing layer’s position (drag&drop) in the Layers panel – the first layer in 

the Layers panel will be on top of other layers in the QGIS map view) 

  

Figure 43: Switching from single-processing to batch-processing spatial difference creation 

Figure 44: Creating 300 – 1000 m and 1 – 10 km strips 
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17. extract only administrative units that are intersecting previously created coastal strips (layer 

coastal-strips.gpkg): 

a. go to Vector ► Research Tools ► Select by location… 

b. in a new dialog window (Figure 48) in the Select features from dropdown choose 

the previously imported .geojson.gz file with administrative units data (❶ on Figure 

48) 

c. tick only intersect geometric predicate (❷ on Figure 48) 

d. in the By comparing to the features from dropdown choose the coastal strips layer 

(coastal-strips.gpkg, ❸ on Figure 48) 

e. clicking on the Run button (❹ on Figure 48), select only those administrative units 

that intersect (i.e. have any point/part in common) – this operation does not 

produce any new data (selected polygons are by default settings colored with 

yellow, as can been seen on Figure 49) 

 

 

Figure 45: Merging 0 – 300 m, 300 – 1000 m, and 1 – 10 km strips into a single layer 

Figure 46: Choosing layers that are going to be merged 
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f. in the Layers panel, right-click on the imported .geojson.gz layer with administrative 

units in which administrative units that intersect coastal strips are selected and 

click on the Export ► Save Selected Features As… (Figure 49) 

g. in a new dialog window, under the Format dropdown choose “GeoPackage” (❶ in 

Figure 50) 

h. click on the three-dots-button (❷ in Figure 50) and define a storage location and 

name for a new GeoPackage file (name file with administrative-units.gpkg) 

i. under Select fields to export and their export options untick all fields except “name”, 

“local_name”, and “name_en” (❸ in Figure 50), and click on the OK button (❹ in 

Figure 50) 

 

 

 

Figure 48: Performing a spatial query (select only administrative units that intersect coastal strips) 

Figure 47: QGIS map view after importing OSM-boundary administrative units data (example for Italy, 

basemap: © OpenStreetMap contributors) 
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18. create an intersection between coastal strips and administrative units produced in the 

previous step, which will produce reporting units: 

a. go to Vector ► Geoprocessing Tools ► Intersection… 

b. in the new dialog window (Figure 51) under the Input layer choose the layer with 

administrative units (administrative-units.gpkg, ❶ on Figure 51) 

c. under the Overlay layer choose the layer with coastal strips (coastal-strips.gpkg, ❷ 

on Figure 51) 

Figure 49: Extracting selected polygons (colored with yellow) from OSM-boundary administrative units data 

(basemap: © OpenStreetMap contributors) 

Figure 50: Exporting selected administrative units in the new GeoPackage file 
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d. click on the three-dots-button under Intersection (❸ on Figure 51), choose Save as 

File…, and define a storage location and name for a new GeoPackage file (name 

file with reporting-units.gpkg) 

e. click the OK button (❹ on Figure 51) to initiate the creation of reporting units 

19. the final step is to clean attribute data in reporting units layer (reporting-units.gpkg): 

a. open attribute table for the reporting-units.gpkg layer (right click on the reporting-

units.gpkg layer name in the Layers panel and click on the Open Attribute Table) 

b. enable layer editing by clicking on the icon marked with ❶ in Figure 52 

c. create a new attribute with coastal strip names (“0 – 300 m”, “300 – 1000 m”, and 

“1 – 10 km”) by clicking on the icon marked with ❷ in Figure 52, which will open 

the Field Calculator window (Figure 53): 

i. make sure that the Create a new field option is ticked, and that the Only 

update # selected features option, if it is available, is unticked (marked with 

❶ in Figure 53) 

ii. in the Output field name filed enter “strip”, which will be the name for a new 

attribute (❷ in Figure 53) 

iii. in the Output field type dropdown select “Text” (❸ in Figure 53) 

Figure 51: Intersecting administrative units with coastal strips and thus producing reporting units 

Figure 52: Editing attribute data for a vector layer 
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iv. for the Output filed length filed enter “30” (❹ in Figure 53) 

v. in the Expression window (marked with ❺ in Figure 53), paste the following 

expression: 

CASE 

WHEN "layer" = 'buffer-300m-dissolved' THEN '0 - 300 m' 

WHEN "layer" = 'strip_300-1000m' THEN '300 - 1000 m' 

WHEN "layer" = 'strip_1-10km' THEN '1 - 10 km' 

ELSE 'ERROR' 

END 

vi. in the area marked with ❻ in Figure 53, look for “layer” item in the “Fields 

and Values” group, click on it, click on the All Unique button (marked with 

❼), and, if needed, replace underlined parts in the above expression with 

corresponding items from the list that was generated under the All Unique 

button (marked with ❽) 

vii. click on the OK button (marked with ❾ in Figure 53), which will close the 

Field Calculator window and after which a new attribute named “strip” will 

be created, and its values will be populated based on the above specified 

expression 

d. some attribute values in the “name_en” attribute/field are not specified, so they 

should be copied from the “name” or the “local_name” attribute/field: 

i. again, open the Field Calculator window by clicking on the icon marked with 

❷ in Figure 52 

ii. tick the Update existing field option (marked with ❶ in Figure 54), and 

make sure that the Only update # selected features option (marked with ❷ 

in Figure 54), if it is available, is unticked 

iii. in a dropdown that is marked with ❸ in Figure 54, choose “name_en” 

iv. in the expression window (marked with ❹), enter the following expression: 

 

 

Figure 53: Creating a new “strip” attribute by defining expression in the Field Calculator window 
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if( 

 "name_en" IS NOT NULL, 

 "name_en", 

 if( 

  "name" IS NOT NULL, 

  "name", 

  "local_name" 

  ) 

 ) 

v. click on the OK button (marked with ❺), which will close the Field 

Calculator window and populate empty attribute values for the “name_en” 

attribute with the attribute values from the “name”, and “local_name” 

attribute, as specified in above expression 

e. remove unnecessary attributes: 

i. click on the icon marked with ❸ in Figure 52 

ii. in a new window (Figure 55) select attributes “fid_2”, “vertex_index”, 

vertex_part”, “vertex_part_index”, “distance”, “angle”, “layer”, and “path” 

(as marked with ❶) 

iii. click on the OK button (marked with ❷ in Figure 55) which will delete 

selected attributes and their values from the attribute table 

f. finally, click on the icon (marked with ❹ in Figure 52) to save all changes that 

have been done in the reporting-units.gpkg layer, and click on the icon  

(marked with ❶ in Figure 52) to disable layer editing 

Figure 54: Updating the “local_name” attribute by defining expression in the Field Calculator window 
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After this processing, the only layers that can be left in QGIS are: aoi.gpkg, coastline-aoi.gpkg, 

administrative-units.gpkg, reporting-units.gpkg, and basemap imported with the QuickMapServices 

plugin. All other layers may be removed from the QGIS project by right-clicking on each of them in 

the Layers panel and then clicking on the Remove Layer… It is also recommended to save the QGIS 

project file (it has a QGZ extension) from time to time by going to File ► Save… As already 

discussed, note that in the QGIS project file no raster or vector data is stored, it only stores locations 

of corresponding files that are stored in the computer storage. Always be sure to retain relative 

location on the computer storage between the QGIS project file and files that are imported into the 

QGIS project. All data that are not necessary for further processing can be deleted from the 

computer storage. 

 

3.4 Preparing other data 

Reporting units that are created in the previous chapter will be used for aggregating LC/LU and 

elevation data, and data on protected areas. In this chapter, these data will be prepared for their 

further processing and aggregation. 

3.4.1 Preparing LC/LU data 

All steps in this chapter, as opposed to steps in the previous chapter with the creation of reporting 

units, need to be done twice, for both years that are chosen for the indicator calculation. In the 

chapters below, the processing of the ESA WCP data for the year 2021 is described as these data 

is proposed for the calculation of the CCI25 baseline data. 

Downloaded ESA WCP GeoTIFF tiles can be imported in QGIS by going to Layer ► Add Layer ► Add 

Raster Layer… In the new dialog window (Figure 56) click on the three-dots-button (❶ in Figure 

56), locate and select the ESA WCP GeoTIFF tile(s) that has to be imported, and finally import it by 

clicking the OK button (❷ in Figure 56). Make sure you have imported (and previously downloaded) 

all ESA WCP raster tiles that overlap with the AOI, that is, more specifically, with created reporting 

units. 

 

Figure 55: Selecting attributes that are about to be deleted 
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If only one raster tile is imported into QGIS, the following steps can be skipped. Otherwise, all 

imported rasters from each year should be merged (i.e. mosaicked) into one so that they can be 

processed jointly. Regular mosaicking (Raster ► Miscellaneous ► Merge…) creates a completely 

new raster which will, in this case, duplicate original data and unnecessarily take additional storage 

space. Another mosaicking approach is to create a so-called virtual raster. A virtual raster only 

points to the original raster data, it takes almost none of the storage space and is in QGIS treated 

as a regular raster. To create a virtual raster that consists of more ESA WCP raster tiles, follow these 

steps: 

1. go to Raster ► Miscellaneous ► Build virtual raster… 

2. in a new dialog window (Figure 57), click on the three-dots-button under Input layers 

(marked with ❶) 

3. in a new window (Figure 58) tick all ESA WCP raster tiles from one year (example for the 

year 2021 marked with ❷) 

4. click on the OK button (marked with ❸ in Figure 58) 

5. after clicking on the three-dots-button marked with ❹ in Figure 57 and choosing Save as 

File…, define the storage location and name for the virtual raster that is about to be created 

(for name, use ESA WCP-<year>.vrt, replace <year> with the corresponding year) 

6. click the Run button to initiate the creation of a virtual raster (❺ in Figure 57) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 56: Importing ESA WCP GeoTIFF tile in QGIS  
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To speed up processing in the next steps, we can create a new raster from previously imported ESA 

WCP rasters or created virtual rasters in which all pixel values that are outside of reporting units 

will be removed, that is, set to appropriate “no data value”. This procedure is in QGIS called clipping. 

We will also increase spatial resolution by 2 times to reduce errors in later calculations. We propose 

the following workflow (separately for each year): 

1. to determine the resolution or pixel size of a ESA WCP raster layer: 

a. right click on one of the previously created virtual rasters in the Layers panel 

b. click on Properties… in the dropdown menu 

Figure 58: Selecting raster layers that will be merged into one virtual raster 

Figure 57: Merging all ESA WCP tiles into one virtual raster 
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c. in the Information tab (on the left side), find the “Pixel Size” entry and copy one of 

the values (for ESA WCP, both values representing north-south and west-east pixel 

sizes should be the same, and to be sure about their correctness, these values 

could also be compared against values for original ESA WCP rasters)  

2. go to Raster ► Extraction ► Clip Raster by Mask Layer… 

3. in a new dialog window (Figure 60) under the Input layer dropdown (marked with ❶) select 

imported ESA WCP raster tile, if it is one for each year, or previously created virtual raster 

(ESA WCP-<year>.vrt) 

4. in the Mask layer dropdown select reporting units vector layer (reporting-units.gpkg, 

marked with ❷ on Figure 60) 

5. ensure Match the extent of the clipped raster to the extent of the mask layer is ticked (❸ 

on Figure 60)  

6. tick the Set output file resolution option and paste 0.000041666666666666665275 in X Resolution 

to output bands and Y Resolution to output bands fields (marked with ❺ on Figure 60) 

which will produce a raster with spatial resolution 2 times higher than the resolution of the 

original ESA WPC raster layer (values in X Resolution to output bands and Y Resolution to 

output bands fields are after pasting shown rounded to six decimal places, but the 

calculation is done with more decimal places, so be sure to paste the whole number to 

avoid later raster misalignments, and also be sure to use the correct decimal separator) 

7. in the Additional command-line parameters (❻ on Figure 61) paste the following text (as 

suggested in [22]): -co COMPRESS=DEFLATE -wo CUTLINE_ALL_TOUCHED=TRUE 

8. after clicking on the three-dots-button marked with ❼ in Figure 61 and choosing Save as 

File…, define the storage location and name for the raster that is about to be created (for 

name, you can use ESA WCP-<year>-clipped.tiff (replace <year> with the corresponding 

year), choose TIF or TIFF as a storage format) 

9. click the Run button to start the clipping algorithm (❽ in Figure 61) 

 

Figure 59: Determining pixel dimensions (i.e. spatial resolution) for raster layers 
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After clipping rasters to reporting units for both years, imported original ESA WCP rasters can be 

removed from the QGIS project (right-click on the layer name in the Layers panel and click on the 

Remove Layer… in the dropdown menu), as well as virtual rasters, if they have been created. An 

example of a ESA WCP raster after clipping to the reporting units is shown in Figure 62. Again, to 

change the draw order of different layers in the QGIS map view, drag&drop layers and change their 

order in the Layers panel. 

 

Figure 61: Clipping virtual raster with ESA WCP land cover data to reporting units (2) 

Figure 60: Clipping virtual raster with ESA WCP land cover data to reporting units (1) 
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Since the classification scheme of ESA WCP data is not the same as the classification needed for 

CCI25, ESA WCP raster data need to be reclassified to the CCI25 classification. To reclassify ESA 

WCP raster tiles, follow these steps (separately for each year): 

1. in the Processing Toolbox panel enter “r.reclass” in the search bar and then double click on 

the r.reclass item (Figure 63) 

2. in a new dialog window (Figure 64), under the Input raster layer dropdown select the clipped 

ESA WCP raster tile (ESA WCP-<year>-clipped.tif, ❶ in Figure 64) 

3. under the Reclass rule text, paste the following text (❷ in Figure 64): 

50                                                      = 1 Built-up 

40                                                      = 2 Agricultural 

10 20 30 60 70 100                                              = 3 Forest and semi-natural land 

90 95                                                   = 4 Wetlands 

80 200                                                  = 5 Waterbodies 

4. in the Output raster format options paste the following text: COMPRESS=DEFLATE (❸ in Figure 

64) 

5. after clicking on the three-dots-button marked with ❹ in Figure 64 and choosing Save as 

File…, define the storage location and name for the raster that is about to be created (for 

Figure 63: Accessing the r.reclass algorithm from the Processing Toolbox panel 

Figure 62: ESA WCP layer after clipping to the reporting units (example for south Italy,  

basemap: © OpenStreetMap contributors) 
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name, use ESA WCP-<year>-reclassified.tif (replace <year> with the corresponding year), 

choose TIF or TIFF storage format) 

6. click the Run button to initiate the creation of a reclassified raster (❺ in Figure 64) 

 

 

After this processing, only layers that can be left in QGIS are: aoi.gpkg, coastline-aoi.gpkg, 

administrative-units.gpkg, reporting-units.gpkg, ESA WCP-<year1>-clipped.tif, ESA WCP-<year2>-

clipped.tif, ESA WCP-<year1>-reclassified.tif, ESA WCP-<year2>-reclassified.tif, and basemap 

imported with the QuickMapServices plugin. 

3.4.2 Preparing elevation data 

As already mentioned, each downloaded FABDEM ZIP archive contains up to 100 1°×1° GeoTIFF 

tiles. From these tiles, the flooding zone needs to be extracted. We suggest the following workflow: 

1. extract all tiles from the downloaded FABEDM ZIP archive (if multiple ZIP archives have 

been downloaded, move all tiles to the same folder) and remove metadata files that have 

an XML extension (do not import tiles into QGIS yet) 

2. like with land cover ESA WCP data, instead of making a “real” mosaic that unnecessarily 

takes storage space and duplicates original data, we can create a virtual raster: 

a. go to Raster ► Miscellaneous ► Build virtual raster… 

b. in a new dialog window (Figure 65), after clicking on the three-dots-button that is 

marked with ❶, a new dialog which is shown in Figure 66 opens 

c. by clicking on the Add Directory… button (❷ on Figure 66) and defining the location 

(i.e. path on the disc) of a directory where all FABDEM tiles have been extracted 

from downloaded ZIP files, we have an option to select raster data for creating 

virtual raster that has not been previously imported into QGIS 

d. after defining a path to the folder with all FABDEM raster tiles, click the OK button 

(❸ on Figure 66) to return to the previous window 

Figure 64: Reclassifying ESA WCP raster tiles to the CCI25 classification scheme 
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e. in the Resolution dropdown choose “Highest” (❹ in Figure 65) 

f. after clicking on the three-dots-button marked with ❺ in Figure 65 and choosing 

Save as File…, define the storage location and name for the virtual raster that is 

about to be created (for name, you can use DEM.vrt) 

g. click the Run button to initiate the creation of a virtual raster (❻ in Figure 65) 

3. again, like with land cover ESA WCP data, we should remove pixel values for all pixels in a 

previously created virtual raster that are outside of reporting units, and also ensure that the 

raster with elevation data is aligned (i.e. pixels in rasters perfectly overlap) with the raster 

with land cover ESA WCP data (expect longer processing time for this step): 

a. go to Raster ► Extraction ► Clip raster by mask layer… 

Figure 65: Merging all FABDEM tiles into one virtual raster (1) 

Figure 66: Merging all FABDEM tiles into one virtual raster (2) 
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b. in a new dialog window (Figure 67) under the Input layer dropdown (marked with ❶) 

select the previously created virtual raster with FABDEM elevation data (DEM.vrt) 

c. in the Mask layer dropdown select reporting units vector layer (reporting-units.gpkg, 

marked with ❷ in Figure 67) 

d. in the Assign a specified nodata value to output bands field enter 9999 (❸ in Figure 67) 

e. ensure that the Match the extent of the clipped raster to the extent of the mask 

layer is ticked (❹ in Figure 67) 

f. tick the Set output file resolution option and paste 0.000041666666666666665275 in 

X Resolution to output bands and Y Resolution to output bands fields (marked with 

❺ in Figure 67) which will, with the tick in the previous step, ensure that the raster 

with FABDEM elevation data and raster with ESA WCP land cover data are aligned 

and have the same resolution (be sure to paste the whole number in X Resolution 

to output bands and Y Resolution to output bands fields) 

g. in the Additional command-line parameters (❻ in Figure 68) paste the following 

text (as suggested in [22]): -co COMPRESS=DEFLATE -wo CUTLINE_ALL_TOUCHED=TRUE 

h. after clicking on the three-dots-button marked with ❼ in Figure 68 and choosing 

Save as File…, define the storage location and name for the raster that is about to be 

created (for name, you can use DEM-clipped.tif, choose TIF or TIFF storage format) 

i. click the Run button to start the clipping algorithm (❽ in Figure 68) 

4. to extract only pixels in the low elevation zone (LEZ) which is also a flooding zone, follow 

this workflow (expect a longer processing time for this step): 

a. in the Processing Toolbox panel enter “Raster calculator” in the search bar and then 

double click on the Raster calculator item from the “GDAL” group (Figure 69) 

b. in the new dialog window (Figure 70) in the Input layer A dropdown (marked with ❶) 

select the previously created clipped elevation data layer (DEM-clipped.tif) 

Figure 67: Clipping virtual raster with FABDEM elevation data to reporting units (1) 
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c. in the Calculation in gdalnumeric syntax field (❷ in Figure 71) enter this logical 

formula:  A <= 5 (in this case, 5 is entered because zone that is less than 5 m above 

sea level is defined as LEZ; make sure to include one space around <=) 

d. in the Set output nodata value field enter 0 (❸ in Figure 71) 

e. in the Output raster type dropdown choose “Byte” (❹ in Figure 71) 

f. in the Additional command-line parameters field enter: --co COMPRESS=DEFLATE (make 

sure to put two minuses at the beginning, as marked with ❺ in Figure 71) 

g. after clicking on the three-dots-button marked with ❻ in Figure 71 and choosing 

Save as File…, define the storage location and name for the raster that is about to 

be created (for name, you can use LEZ.tif, choose TIF or TIFF storage format) 

h. click the Run button to start raster creation based on the entered formula (❼ in 

Figure 71) 

Figure 68: Clipping virtual raster with FABDEM elevation data to reporting units (2) 

Figure 69: Accessing the GDAL’s Raster calculator from the Processing Toolbox panel 

Figure 70: Extracting LEZ from FABDEM with GDAL’s Raster Calculator (1) 
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5. to polygonize (convert raster layer to a vector one) raster created in the previous step with 

pixel values being 1, if logical formula A <= 5 is evaluated as true, or 0 if it is evaluated as 

false (in produced raster, pixels with value 1 are pixels from DEM-clipped.tif that have 

elevation less or equal to 5), follow this workflow: 

a. go to Raster ► Conversion ► Polygonize (Raster to Vector)… 

Figure 71: Extracting LEZ from FABDEM with GDAL’s Raster Calculator (2) 

Figure 72: Polygonizing raster layer with low elevation zone (LEZ) 
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b. in the new dialog window (Figure 72), in the Input layer dropdown (marked with ❶), 

choose the raster that is previously created with the Raster Calculator algorithm 

(LEZ.tif)  

c. tick the Use 8-connectedness option (marked with ❷ in Figure 72) 

d. after clicking on the three-dots-button that is marked with ❸ in Figure 72 and 

choosing Save as File…, define the storage location and name for the vector layer 

that is about to be created (for name, you can use LEZ.gpkg, and choose the GPKG 

storage format) 

e. click the Run button to start the polygonization algorithm (❹ in Figure 72) 

6. it is likely that the previously created vector layer (LEZ.gpkg) contains polygons that 

correspond to areas that have an elevation below 5 m ASL but are not contiguous to the 

coastline, and they should be removed: 

a. go to Vector ► Research Tools ► Select by Location… 

b. in a new dialog window (Figure 73), in the Select features from the dropdown 

(marked with ❶) select a layer that was previously created by the polygonization 

algorithm (LEZ.gpkg) 

c. make sure intersect option is the only one that is ticked under the Where the 

features (geometric predicate) (❷ in Figure 73) 

d. in the By comparing to the features from select vector layer with coastline data 

(coastline-aoi.gpkg, as marked with ❸ in Figure 73) 

e. make sure that in Modify current selection by “creating new selection” is the chosen 

option (❹ in Figure 73) 

f. click the Run button to start the algorithm that will select all polygons in the 

LEZ.gpkg vector layer that spatially have anything, even a single point in common 

with the coastline – selected polygons are highlighted with yellow color in the QGIS 

map view, as is visible in Figure 75 (notice that this algorithm, as opposed to the 

most of the previous ones, does not produce any new data) 

g. open the attribute table for the LEZ.gpkg layer by right-clicking on the layer name 

(“LEZ”) in the Layers panel and selecting Open Attribute Table (as highlighted in 

Figure 75) 

h. in the attribute table (Figure 74), click on the icon (❶) to invert the selection 

(rows that correspond to the selected polygons/features are highlighted with blue 

color), enable layer editing by clicking on the icon (❷), delete all selected 

Figure 73: Selecting polygons in the LEZ.gpkg layer that intersect with coastline 
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polygons/features by clicking on the  icon (❸), save edits by clicking on the  

icon (❹), and finally click again on the  icon (❺) to disable layer editing 

Some features/polygons in the generated LEZ.gpkg vector layer have topological errors, that will 

prevent some algorithms from making processing with them (this can be checked by going to Vector 

► Geometry Tools ► Check Validity…). To fix those topological errors, you can use the Fix 

geometries algorithm. The Fix geometries algorithm can be accessed through the Processing 

Toolbox by entering “fix geometries” in the search bar, and double clicking on the “Fix geometries” 

item (Figure 76). After double-clicking, in a new dialog window (Figure 77): 

1. under the Input layer dropdown choose the LEZ.gpkg layer (marked with ❶ in Figure 77) 

Figure 75: Selected polygons are highlighted with yellow color (by default settings) and all other remain in color 

assigned in corresponding layer settings – in this case, green (basemap: © OpenStreetMap contributors) 

Figure 74: Removing features from the vector layer 
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2. after clicking on the three-dots-button that is marked with ❷ in Figure 77 and choosing 

Save as File…, define the storage location and name for the vector layer that is about to be 

created (for name, you can use LEZ-fixed.gpkg, and choose the GPKG storage format) 

3. click the Run button (❸ in Figure 77) to start the algorithm that will create a new LEZ-

fixed.gpkg layer with fixed topological errors from the LEZ.gpkg layer 

To make some further calculations easier, remove LEZ.gpkg layer from the QGIS project, dissolve 

LEZ-fixed.gpkg layer by going to Vector ► Geoprocessing Tools ► Dissolve…, and name the output 

layer LEZ.gpkg (choose GPKG storage format and confirm the prompt that asks if you want to 

replace existing LEZ.gpkg layer). 

3.4.3 Preparing data on protected areas 

The downloaded ZIP archive with the WDPA data on protected areas firstly needs to be unzipped. In the 

unzipped folder, there is one or more (mostly three) ZIP archives with the Esri shapefiles. Combined 

data from all these ZIP archives contain all WDPA data for the area of interest. Each ZIP archive again 

needs to be unzipped. Only Esri shapefiles that have a name ending with “polygon” need to be further 

processed in QGIS since they contain polygonal vector layers. All polygonal vector layers need to be 

merged into one layer, and then two layers have to be generated out of the merged layer: one with 

polygons that correspond to protected areas that were established before the first year that is chosen 

for CCI25 calculation, and another one for areas that were established before the second chosen year. 

To merge multiple Esri shapefile polygon layers without firstly importing them in QGIS, follow these 

steps: 

Figure 76: Accessing the Fix geometries algorithm from the Processing Toolbox panel 

Figure 77: Running the Fix geometries algorithm 
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1. go to Vector ► Data Management Tools ► Merge Vector Layers… 

2. in the new dialog window (Figure 78), click on the three-dots-button that is marked with ❶ 

3. in a new window (Figure 79), click on the Add File(s)… button (marked with ❷), navigate to 

one of the folders created after unzipping ZIP archives, and select the file that ends with 

“…polygons.shp” 

4. repeat the previous step for each unzipped ZIP archive 

5. make sure only previously selected files that end with “…polygons.shp” are ticked (in the 

example shown in Figure 79, three files ending with “…polygons.shp” are ticked, as marked 

with ❸) 

6. click the OK button (❹ in Figure 79), which will again open the previous window 

7. after clicking on the three-dots-button that is marked with ❺ in Figure 78 and choosing 

Save as File…, define the storage location and name for the vector layer that is about to be 

created (for name, you can use protected-areas.gpkg and choose the GPKG storage format) 

8. click the Run button to start merging vector layers algorithm (❻ in Figure 78) 

The next task would be extracting protected areas based on the year they have been established. 

Since some protected areas are spatially overlapping (e.g., the same zone can be protected on 

Figure 78: Merging multiple vector layers (1) 

Figure 79: Merging multiple vector layers (2) 
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different levels or different bases), we will also dissolve all protected areas. By dissolving the 

polygonal vector layer, all polygons that are overlapping will be flattened in a single polygon in the 

output layer. It is also important to know that each polygon/feature in the protected areas layer has 

an attribute “STATUS” that can have values: “Proposed”, “Inscribed”, “Adopted”, “Designated”, 

“Established”, and “Not Reported”. All polygons that have a value for the “STATUS” attribute either 

“Proposed” or “Not Reported” should not be used in further calculations. Follow these steps to take 

all this into account and make sure to go through them twice, for both years that are chosen for 

CCI25 calculation: 

1. right click on the name of the previously created vector layer with merged protected areas 

(protected-areas.gpkg) in the Layers panel and click on Filter… 

2. in an opened Query Builder window (Figure 80) find “STATUS” within the Fields list (marked 

with ❶), select it, and click the All button (marked with ❷) 

3. in the Values list check if there are values “Proposed” or “Not Reported”, or some other 

unsuitable value (in Figure 80, only values “Adopted”, “Designated” and “Inscribed” are 

present) 

4. now define an expression under Provider Specific Filter Expression based on which data 

will be filtered (marked with ❸ in Figure 80): 

a. double click on the “STATUS_YR” in the Fields list, which will insert the “STATUS_YR” 

attribute name in the correct form in the Provider Specific Filter Expression filed 

b. click on the <= button, which will again insert “<=” in the Provider Specific Filter 

Expression filed 

c. manually enter a year in the Provider Specific Filter Expression filed (in Figure 80 it 

is “2015”) 

d. if there are no unsuitable values within the Values list for the “STATUS” attribute, 

the final expression would be "STATUS_YR" <= <year> (<year> should be replaced with 

the correct year), and if there are unsuitable values, then expression should be 

further expanded to take them into account, for example: 

i. if there is a value “Proposed” within the Values list for the “STATUS” attribute, 

final expression should be: "STATUS_YR" <= <year> AND "STATUS" != 'Proposed' 

ii. if there are values “Proposed” and “Not Reported”, final expression should 

be: "STATUS_YR" <= <year> AND "STATUS" NOT IN ('Proposed', 'Not Reported') 

Figure 80: Filtering features in vector based on values of their attributes 
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5. after clicking on the OK button (marked with ❹ in Figure 80) polygons/features will be 

filtered based on the defined expression, i.e., all features that do not fulfil 

conditions from the expression will remain stored within the layer, but will not be shown it 

the map view and will not be used in any processing with this layer, also, next to the layer 

name in the Layers panel, there will be shown a icon  

6. to dissolve polygons in this layer, go to Vector ► Geoprocessing Tools ► Dissolve… 

7. in a new dialog window (Figure 81), under the Input layer dropdown (marked with ❶) 

choose the layer with protected areas that was previously filtered (protected-areas.gpkg) 

8. after clicking on the three-dots-button that is marked with ❷ in Figure 81 and choosing 

Save to File…, define the storage location and name for the vector layer that is about to be 

created (for name, you can use protected-areas-<year>.gpkg, replace <year> with the 

correct year (same that was used for filtering), and choose the GPKG storage format) 

9. click the Run button to start the dissolving algorithm (marked with ❸ in Figure 81) 

10. open attribute table of the created vector layer (protected-areas-<year>.gpkg) and delete 

all attributes except “fid” 

Figure 81: Dissolving features in a vector layer 

Figure 82: Accessing Query Builder through layer properties 
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Again, make sure to follow the previous steps twice, for both years that are chosen for CCI25 

calculation. After finishing with dissolving protected areas for both years, the filer can be removed 

by deleting the filter expression in the Query Builder window. As already mentioned, the Query 

Builder window can be accessed by right-clicking on the layer name in the Layers panel and then 

clicking on the Filter…, but it can also be accessed through layer properties: 

1. right click on the layer name in the Layers panel and then click on the Properties… 

2. go to the Source tab on the left side 

3. click on the Query Builder button (as highlighted in Figure 82) 
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4 CALCULATING INDICATOR PARAMETERS 

After processing that is done in previous chapters, all layers that are needed for further processing 

should be prepared. In the QGIS project, layers that should be present are:  

− aoi.gpkg 

− coastline-aoi.gpkg 

− administrative-units.gpkg 

− reporting-units.gpkg 

− ESA WCP-<year1>-clipped.tif 

− ESA WCP -<year2>-clipped.tif 

− ESA WCP -<year1>-reclassified.tif 

− ESA WCP -<year2>-reclassified.tif 

− DEM-clipped.tif 

− LEZ.gpkg 

− protected-areas.gpkg 

− protected-areas-<year1>.gpkg 

− protected-areas-<year2>.gpkg 

− (and basemap imported with the QuickMapServices plugin) 

All other layers that are not in the above list can be removed from the QGIS project and can also be 

deleted from the computer storage. Some of the layers mentioned above are not directly needed 

in further steps, but it is advised to keep them stored since they contain useful information that 

might be needed at some point, especially if some steps would have to be reprocessed. In the 

following sections, we will first overlay vector layers, and then raster layers with reporting units. 

After overlaying and area calculations, we will export data to spreadsheets and calculate indicator 

parameters. 

4.1 Overlaying vector data with the reporting units 

4.1.1 Overlaying data on protected areas with reporting units 

To overlay two layers with data on protected areas with reporting units, go to Vector ► 

Geoprocessing Tools ► Intersection…, click on the Run as Batch Process…button, click once on 

the  button, and define options by following the example shown in Figure 83 (for names of the 

output layers, you can use RU-protected-areas-<year1>.gpkg and RU-protected-areas-

Figure 83: Intersecting layers with protected areas with reporting units 
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<year2>.gpkg, and choose GPKG storage format). Open the attribute table for both layers, open 

the Field Calculator window, and for both layers create a new attribute by following the options 

shown in Figure 84 and save edits done in an attribute table. Function $area will calculate the area 

of each polygon in the vector layer on the surface of the ellipsoid that was defined in the project 

settings and will present those areas in the unit that was also defined in the project settings. 

4.1.2 Overlaying LEZ with reporting units 

Again, go to Vector ► Geoprocessing Tools ► Intersection… to overlay LEZ layer with reporting 

units layer. Define all options in the same way as in Figure 85, name the output layer with RU-

LEZ.gpkg and choose the GPKG storage format. Open the attribute table and then in the Field 

Figure 84: Defining a new attribute in the Field Calculator window 

Figure 85: Intersecting LEZ layer with reporting units layer 
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Calculator window and create a new attribute with values that correspond to the area of each 

polygon (the same as in Figure 84). When finished, save edits done in the attribute table. 

4.1.3 Calculating areas of reporting units 

In reporting units layer, create a new attribute with values that correspond to the area of each 

polygon by opening the attribute table for the reporting units layer, and following settings in the 

Field Calculator window from Figure 86. When finished, save edits that are done in the attribute 

table. 

4.2 Overlaying raster LC/LU data with the reporting units 

We first need to calculate the area of each pixel in the LC/LU raster on the surface of the ellipsoid, 

then extract pixels that correspond to each LC/LU class, and sum their areas for each reporting 

unit. To calculate the area for each pixel, enter “r.mapcalc.simple” in the search bar of the 

Processing Toolbox panel and double-click on the r.mapcalc.simple item. In a new window (Figure 

87), in the Raster layer A dropdown choose any of the clipped or reclassified ESA WCP layers. In the 

Formula field enter area(), and in the Output Raster format options field enter COMPRESS=DEFLATE. 

For the name choose area.tif and click on the Run button to start the algorithm. 

 

Now we will use the raster calculator to extract pixels from the area.tif raster that correspond to 

each LC/LU class and separately for each year that is chosen for CCI25 calculation. In the 

Processing Toolbox panel enter “Raster calculator” in the search bar and then double click on the 

Raster calculator item from the “GDAL” group (Figure 69). In the Input layer A choose reclassified 

ESA WCP layer for one of the years that were chosen for CCI25 calculation (in the example in Figure 

88 ESA WCP-<year1>-reclassified.tif was chosen). Under the Input layer B choose the previously 

created area.tif raster layer. In the Calculation in gdalnumeric syntax field enter (A==1)*B, in the Set 

output nodata value enter “0”, in the Output raster type dropdown choose “Float32”, in the 

Additional command-line parameters enter --co COMPRESS=DEFLATE, define the name of the output 

layer as built-up-<year1>.tif, and click on the Run button. The layer was named built-up-<year1>.tif 

because in reclassified CGLS-LC100 raster, pixels with value 1 match to built-up class, which 

corresponds to the defined expression (A==1)*B. This processing has to be done for additional nine 

Figure 86: Defining a new attribute in the Field Calculator window 
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times: the first four times with the ESA WCP-<year1>-reclassified.tif layer chosen under the Input 

layer A dropdown, and five times with the ESA WCP -<year1>-reclassified.tif layer. Every time you 

need to change the expression in the Calculation in gdalnumeric syntax field and output layer name. 

When the expression is (A==2)*B, the output layer name should be agricultural-<year#>.tif, when 

the expression is (A==3)*B, it should be forest-seminatural-<year#>.tif, when the expression is 

(A==4)*B, it should be wetlands-<year#>.tif, and when the expression is (A==5)*B, it should be 

waterbodies-<year#>.tif. After this processing, 10 new raster layers should be produced:

− built-up-<year1>.tif 

− agricultural-<year1>.tif 

− forest-seminatural-<year1>.tif 

− wetlands-<year1>.tif 

− waterbodies-<year1>.tif 

− built-up-<year2>.tif 

− agricultural-<year2>.tif 

− forest-seminatural-<year2>.tif 

− wetlands-<year2>.tif 

− waterbodies-<year2>.tif 

Pixel values in these rasters are areas of each pixel in square meters, but only pixels that 

correspond to the particular LC/LU class, and all other pixels have a value “0”. We could not speed 

up this processing with the batch processing option, since batch processing does not allow defining 

all the necessary settings. 

Figure 87: Calculating area for each pixel in the ESA WCP raster layers 

Figure 88: Using GDAL’s Raster Calculator to extract pixels from the area.tif raster that correspond to a 

particular LC/LU class (1) 
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We will now use the zonal statistics algorithm to sum all the pixel values from the previously created 

raster layers that fall within each reporting units polygon. Enter “Zonal statistics” in the Processing 

Toolbox panel and double-click on the Zonal statistics item. In a new dialog window click on the Run 

as Batch Process… button, and then press the  button nine times. Under the Input layer and 

Raster layer select the same layer as in the example in Figure 90. In the Statistics to calculate 

column, for each row click on the three-dots-button and tick only the “Sum” item. Name the output 

vector layers in the same way as in the example in Figure 91, make sure the Load layers on 

completion option is ticked, and click on the Run button. 

Figure 89: Using GDAL’s Raster Calculator to extract pixels from the area.tif raster that correspond to a 

particular LC/LU class (2) 

Figure 90: Using the Zonal statistics algorithm to sum areas of each LC/LU class within each reporting unit (1) 
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The same processing that was done with the Zonal statistics algorithm needs to be done again, but 

this time within LEZ across reporting units. All settings should be the same as on Figure 90 and 

Figure 91, except that Input layer should be changed to RU-LEZ.gpkg in all rows and names of the 

output vector layers need to be changed. Names can be changed by just adding prefix “LEZ-“ to 

already defined output layer names that are visible in Figure 91 (for example, name of the layer in 

the first row in Figure 91 should be changed to LEZ-built-up-2021.gpkg). This will produce another 

10 new layers, so with Zonal statistics algorithm 20 new layers will overall be created. 

 

4.3 Combining all calculated data in one table 

After all processing that was done in the previous sections, all data that are required for final CCI25 

calculation are prepared and stored in corresponding attribute tables, and they just need to be 

merged into one table. In the Layers panel, right click on the layer with original reporting units 

(reporting-units-gpkg), and click on the Properties… In the Layer Properties window, in the Joins tab 

(on the left side of the window) click on the button. In a new window (visible in Figure 92) 

define settings for joining attribute data of two vector layers and repeat this step for every layer that 

was produced with the Intersection and the Zonal statistics algorithm. For joining data from the RU-

LEZ.gpkg layer follow setting from the left screenshot in Figure 92, and for each of two layers 

produced with intersecting reporting units with protected areas (RU-protected-areas-<year1>.gpkg 

and RU-protected-areas-<year2>.gpkg) follow settings from right screenshot. For each of the first 

10 layers that were produced with the Zonal statistics algorithm (those layers that do not have a 

“LEZ-” prefix in their name), follow settings from the left screenshot in  Figure 93, and for the second 

10 created layers (those that have a “LEZ-” prefix in their name) use settings from right screenshot. 

After defining all these joins, the Joins tab of the reporting-units.gpkg layer should look like the one 

on Figure 94. When joining attribute data, it is necessary to pay attention to the columns 

representing join field and target field as highlighted on Figure 93 and Figure 94. While target field 

is always “fid” join field could be “fid” or “fid_2”. 

 

Figure 91: Using the Zonal statistics algorithm to sum areas of each LC/LU class within each reporting unit (2) 
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Figure 92: Joining data from attribute table of RU-LEZ.gpkg, and RU-protected-areas-2021.gpkg layers with 

data from attribute table of reporting-units.gpkg layer 

Figure 93: Joining data from attribute table of built-up-2021.gpkg and LEZ-built-up-2021.gpkg layers with 

data from attribute table of reporting-units.gpkg layer 
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After clicking on the OK button in the Layer Properties window (Figure 94), attribute table of the 

reporting-units.gpkg layer should be populated with all data that are needed for calculating CCI25 

parameters. In the Layers panel, right click on the reporting units layer (reporting-units.gpkg), 

choose Export, and then Save Features As… In a new Save Vector Layer As… dialog window (Figure 

95), in the Format dropdown choose XLSX, in the File name field define name and storage location 

of the output file (you can use CCI25-calculation.xlsx for name) and click on the OK button. 

 

 

 

 

 

Figure 95: Exporting data from attribute table in XLSX file 

Figure 94: Joins tab of the reporting-units.gpkg layer after defining all joins 
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4.4 Calculating indicator parameters and representing results 

XLSX file that was exported from QGIS contains all data that is necessary to calculate CCI25 

parameters. We suggest that before conducting any other calculations, you divide all values in all 

cells in a spreadsheet that represent area with 1000000 so that results are expressed in km2, 

instead of m2. These are the parameters that have to be calculated for first monitoring: 

1. km2 of built-up area in coastal zone 

2. % of built-up area in coastal zone 

3. % of other land cover classes in coastal zone 

4. % of built up area within coastal strips of different width compared to wider coastal 

units 

5. % of other land cover classes within coastal strips of different width compared to wider 

coastal units 

6. km2 of protected areas within coastal strips of different width 

7. km2 of LEZ 

8. km2 of built-up area within LEZ 

9. % of built-up area within LEZ 

10. % of built-up area within LEZ compared to coastal administrative unit 

11. % of other land cover classes within LEZ 

12. % of other land cover classes within LEZ compared to coastal administrative unit 

13. km2 of protected areas within LEZ in coastal zone 

 

For the second monitoring, these parameters have to be calculated: 

1. % of increase of built-up area, or land take 

2. % of change of other land cover classes 

3. % of change of protected areas 

4. % of increase of built-up area, or land take within LEZ 

5. % of change of other land cover classes within LEZ 

6. % of change of protected areas within LEZ 

 

All these parameters can be calculated by applying suitable filters and summing values in XLSX file 

or by creating pivot tables. We also suggest that you convert range with values (not empty cells) to 

table. In Microsoft Excel, to convert range to table, select one cell that is within the range, and then 

choose one of the predefined table styles after clicking on the Format as table in Styles group in 

the Home ribbon. After converting to table, spreadsheet should look similar to the one in Figure 96. 

 

In columns B, C, and D are the names of the administrative units, and in column E are the names 

of the coastal strips (“0 – 300 m”, “300 – 1000 m”, and “1 – 10 km”). In all other columns to the 

right of the column E are areas that are in example in Figure 96 already divided by 100000, so they 

Figure 96: Spreadsheet after converting rage to table 
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are expressed in km2. To create a pivot table in Microsoft Excel, go to the Insert tab and click on 

the Pivot Table button and then by draging&dropping column/field names in Filters, Columns, 

Rows, and Values areas generate different pivot tables and calculate CCI25 parameters. 

 

In tables and figures below, there are some examples and suggestions how can results of indicator 

calculation be visualizes in form of tables or graphs. 

 

Table 1: Areas by CCI25 LC/LU classes in the coastal zone (0 – 10 km) and their percentage for Albania, 

year 2015 

2015  
Built-

up 

areas 

Agricultural 

land 

Forest and 

semi-natural 

land 

Wetlands 
Water 

bodies 

Total 

coastal 

zone 

Albania Area in km 2 166.52 1,289.57 1,712.20 36.11 197.56 3,401.96 

  % in coastal zone 4.89 37.91 50.33 1.06 5.81 100.00 

Durrës County Area in km 2 55.73 215.13 152.08 2.29 7.64 432.86 

 % in coastal zone 12.87 49.70 35.13 0.53 1.77 100.00 

Fier County Area in km 2 12.05 271.41 97.67 11.18 86.52 478.82 

 % in coastal zone 2.52 56.68 20.40 2.33 18.07 100.00 

Gjirokastër County Area in km 2 0.00 0.22 8.68 0.00 0.00 8.89 

 % in coastal zone 0.00 2.47 97.53 0.00 0.00 100.00 

Lezhë County Area in km 2 27.90 240.65 156.42 13.11 17.06 455.13 

 % in coastal zone 6.13 52.87 34.37 2.88 3.75 100.00 

Shkodër Area in km 2 3.11 77.61 46.79 2.20 6.72 136.44 

 % in coastal zone 2.28 56.89 34.30 1.61 4.93 100.00 

Tirana County Area in km 2 22.22 137.95 109.70 0.59 4.75 275.22 

 % in coastal zone 8.08 50.13 39.86 0.21 1.73 100.00 

Vlorë County Area in km 2 45.50 346.60 1,140.88 6.74 74.88 1,614.60 

 % in coastal zone 2.82 21.47 70.66 0.42 4.64 100.00 
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Land cover / land use in Albania coastal zone (2015)    
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Forest and seminatural areas

Wetlands

Water bodies

Figure 97: CCI25 LC/LU classes in Albanian coastal zone (0 – 10 km), year 2015 



 

62 

 

 

 

 

 

 

 

 

0 200 400 600 800 1,000 1,200 1,400 1,600 1,800

Vlorë County

Tirana County

Shkodër

Lezhë County

Gjirokastër County

Fier County

Durrës County

Land cover / land use in coastal zone per county in Albania (km2, 2015) 

Built-up areas Agricultural Forest and seminatural areas Wetlands Water bodies

Figure 98: Areas of CCI25 LC/LU classes in Albanian coastal zone (0 – 10 km) per county, year 2015 
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Figure 99: Percentages of CCI25 LC/LU classes in Albanian coastal zone (0 – 10 km) per county, year 2015 
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Figure 100: Built-up areas in Albanian coastal zone (0 – 10 km) per counties per coastal strips, year 2015 
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Figure 101: Change (in km2) in CCI25 LC/LU classes in Albanian coastal zone (0 – 10 km) per 

county, from 2015 to 2018 
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Table 2: LC/LU change from 2015 to 2018 in km2 and percentages per Albanian counties, 

per coastal strips 

 Coastal strips 
Coastal 

zone 
Coastal strips 

Coastal 

zone 

2018 – 2015 

0 -

300 

m 

300 m 

-1 km 

1 - 10 

km 

0 - 10 

km 

0 -  

300 m 

300 m 

-  

1 km 

1 - 

10 km 
0 - 10 km 

Built-up areas Areas in km2 Change in percentage (2018-2015)/2015 

Durrës County 0.02 0.00 0.03 0.05 0.60 0.00 0.07 0.09 

Fier County 0.00 0.00 0.02 0.02 0.00 0.00 0.17 0.17 

Gjirokastër County 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00 

Lezhë County 0.05 0.00 0.07 0.12 6.10 0.00 0.27 0.43 

Shkodër County 0.00 -0.25 -0.70 -0.95 0.00 -26.32 -36.65 -30.45 

Tirana County 0.00 0.00 0.01 0.01 0.00 0.00 0.05 0.05 

Vlorë County 0.00 -0.40 -0.17 -0.57 0.00 -4.25 -0.56 -1.25 

Total 0.07 -0.65 -0.74 -1.32 0.60 -2.96 -0.56 -0.79 

Agricultural land Areas in km2 Change in percentage (2018-2015)/2015 

Durrës County -0.17 -0.45 0.03 -0.59 -10.63 -4.51 0.01 -0.27 

Fier County -0.04 -0.24 -0.93 -1.21 -26.67 -11.82 -0.35 -0.45 

Gjirokastër County 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00 

Lezhë County -0.17 -0.31 -0.69 -1.17 -16.83 -5.36 -0.30 -0.49 

Shkodër County -0.09 -0.09 -0.30 -0.48 -39.13 -4.19 -0.40 -0.62 

Tirana County -0.11 -0.11 -0.14 -0.36 -11.83 -1.25 -0.11 -0.26 

Vlorë County -0.10 0.85 3.22 3.97 -4.85 10.81 0.96 1.15 

Total -0.68 -0.35 1.19 0.16 -11.37 -0.96 0.10 0.01 

Forest and semi-natural land Areas in km2 Change in percentage (2018-2015)/2015 

Durrës County -0.56 -0.14 -0.67 -1.37 -5.49 -0.70 -0.55 -0.90 

Fier County -0.51 -1.38 -5.19 -7.08 -30.00 -14.10 -6.02 -7.25 

Gjirokastër County 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00 

Lezhë County -1.14 -1.38 -1.83 -4.35 -27.08 -10.92 -1.31 -2.78 

Shkodër County -0.30 -0.16 -0.26 -0.72 -27.03 -3.11 -0.64 -1.54 

Tirana County -0.38 -0.42 -0.65 -1.45 -7.85 -3.85 -0.69 -1.32 

Vlorë County -1.16 -2.44 -6.52 -10.12 -2.08 -2.16 -0.67 -0.89 

Total -4.05 -5.92 -15.12 -25.09 -5.20 -3.45 -1.03 -1.47 

Water bodies Areas in km2 Change in percentage (2018-2015)/2015 

Durrës County 0.00 -0.01 0.08 0.07 0.00 -1.64 3.10 0.92 

Fier County 0.18 -0.11 -0.24 -0.17 1.69 0.00 0.00 -0.20 

Gjirokastër County 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00 

Lezhë County -0.12 -0.17 0.01 -0.28 -1.73 -3.05 0.22 -1.64 

Shkodër County -0.02 -0.03 -0.10 -0.15 -1.12 -3.70 -2.43 -2.23 

Tirana County -0.01 0.00 0.07 0.06 -0.36 0.00 6.73 1.26 

Vlorë County 0.10 0.09 0.80 0.99 1.25 1.43 1.32 1.32 

Total 0.13 -0.23 0.62 0.52 0.38 -0.75 0.47 0.26 

Wetlands Areas in km2 Change in percentage (2018-2015)/2015 

Durrës County 0.71 0.60 0.53 1.84 94.67 68.97 79.10 80.35 

Fier County 0.37 1.72 6.34 8.43 25.52 46.74 104.79 75.40 

Gjirokastër County 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00 

Lezhë County 1.38 1.85 2.44 5.67 40.12 42.73 45.78 43.28 

Shkodër County 0.41 0.26 0.67 1.34 53.25 49.06 74.44 60.91 

Tirana County 0.49 0.53 0.72 1.74 326.67 441.67 225.00 294.92 

Vlorë County 1.16 1.90 2.67 5.73 123.40 82.97 76.29 85.14 

Total 4.52 6.86 13.37 24.75 60.27 58.04 79.73 68.58 
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Table 3: Areas in LEZ across LC/LU classes in Albanian coastal zone (0 -10 km) per counties 
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Figure 102: Area in km2 of built-up LC/LU class in LEZ in different coastal strips, per counties in Albanian 

coastal zone (0 – 10 km) 
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Figure 103: Percentages of areas in LEZ across LC/LU classes in Albanian coastal zone (0 -10 km) per 

counties 
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Maps are an important part of the report because they show the spatial distribution of CCI25 

parameters. Since one of the results of the calculation is a GIS database, the report can contain 

basic maps and those showing details specific to a given geographical area and CCI25 parameters. 

Below are some examples of maps including choropleth and diagram maps. Although not necessary 

for overview maps, maps should include a scale and a legend. When coastal areas cover large 

areas, it is necessary to create map tiles, e.g. by QGIS Atlas function, in order to ensure a sufficiently 

readable map having an adequate map scale.  

 

 

 

 

 

 

 

Figure 104: Overview map showing percentages of built up area in the lowest level of administrative units 

overlaid with coastal strips (author: Samah Termos) 
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Figure 105: Diagram maps showing percentages of land cover change on the governorate (left map) and 

district level (right map) (author: Samah Termos) 
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Figure 106: Detailed map showing reporting units layer (combination of coastal strips and administrative 

units) 

Figure 107: Detailed map showing Built up areas along the narrower coastal strip in Croatia (areas around 

the city of Zadar) 
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4.5 Validation steps 

 

When performing GIS operations, it is always a good practise to validate obtained results after each 

processing step. This can be done, for example, by brief visual inspection or by performing some 

simple checks on aggregated results (e.g., total areas of reporting units should match to sums of 

areas of specific land cover classes). To avoid situations that some errors in initial processing steps 

are propagated to the last steps, suggested “checkpoints”, or control steps, are the following: 

1. Initial validation of acquired input data (visual inspection, level of uncertainty, suitability 

for CCI25 calculations, etc.); 

2. Control steps after challenging processing stages (e.g., construction of coastal strips 

and reporting units); 

3. Control step after reclassification of initial LCLU classes to CCI25 classes (visual 

inspection, comparison with other sources, especially for classes that have ambiguous 

definitions); 

4. Control step aimed at ensuring that attribute data from GIS layers have been correctly 

joined; 

5. Control steps for calculations performed in spreadsheet application (for example, 

aggregating results and comparing totals). 
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